# Issue: The Apache Tomcat XX TomcatXX service terminated

**URL:** <https://community.automationedge.com/t/issue-the-apache-tomcat-xx-tomcatxx-service-terminated/9904>\
**Category:** AutomationEdge Server\
**Created:** [June 27, 2023, 9:28am UTC](https://community.automationedge.com/t/issue-the-apache-tomcat-xx-tomcatxx-service-terminated/9904 "2023-06-27T09:28:51Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jane](https://avatars.discourse-cdn.com/v4/letter/j/ecb155/32.png) [@Jane](https://community.automationedge.com/u/Jane)\
**Post date:** [June 27, 2023, 9:28am UTC](https://community.automationedge.com/t/issue-the-apache-tomcat-xx-tomcatxx-service-terminated/9904/1 "2023-06-27T09:28:51Z")

</div>

If you encounter the following popup error message while starting

 ![image](https://canada1.discourse-cdn.com/flex027/uploads/automationedge/original/2X/2/2e1022ddc133eefb83447528887fbde9304e6b41.png)

And in the log files you see:  
The Apache Tomcat XX TomcatXX service terminated with the following service-specific error: Incorrect function.

Try to apply the following as a resolution:  
This error occurs when JDK on your machine is not installed.

To resolve this:

- Check the java version installed on the machine. Perform java -version on cmd to check

- Check the JAVA\_HOME and JRE\_HOME environment variable are pointing to the correct path or not

- Install JDK of the same version as JRE if not installed

- Double click on the tomcat9w.exe file from apache-tomcat/bin location

- Click on the JAVA tab and Check the Use Default option for the Java Virtual Machine option.

![](https://desk.zoho.in/DocsDisplay?zgId=60001911841&mode=inline&blockId=393okffb64539bb524a579fafd5693b53ff0f)

- Now start the tomcat service

---

<div class="post-metadata">

**Author:** ![Jane](https://avatars.discourse-cdn.com/v4/letter/j/ecb155/32.png) [@Jane](https://community.automationedge.com/u/Jane)\
**Post date:** [June 28, 2023, 5:05am UTC](https://community.automationedge.com/t/issue-the-apache-tomcat-xx-tomcatxx-service-terminated/9904/2 "2023-06-28T05:05:31Z")

</div>

This is an information blog.
