AE Does not recognize Google Chrome alert pop-up


My process studio does not recognize Google Chrome alert pop-up that appears every time I run a workflow. Since my company obliges me to use a proxy.

I tried using Autoit step, but that did not work. F

Is there a tool I can use to catch this pop-up?

You maybe could use Surface steps. There is a spytool for that.
Surface tool searches for images and places the cursor on the place you specify, left, right, center,etc. Then WebActions you can write.
If the popup is the focused window, you could just use WebActions and move around with Tabs and Enter.
Good luck

1 Like

For some reason, even using Surface, I can’t find the popup

It’s like it’s not part of the browser

Hi Borba, Surface plugins has nothing to do with browser. If what you are looking for can be seen on the display, it should capture it.
Maybe it needs some tweaking. Capture text with fields. Not only the fields. There should be an acker item with the image to capture.

I found the problem with Surface, as I use two screens, for some reason Surface can’t capture both


Yes, that is true. I have 3 screens and to capture surface, it is on screen 1. When executing WF, it should work on any screen.
So it worked?

My monitors’ resolutions are different, and due to the way they’re connected, my primary monitor is smaller than my second monitor. So, it cuts off a larger part of the monitor

For surface you don’t capture the whole screen, only the part of the screen you would like to interact with.

I know, but I believe that when looking for the element on my screen, the Surface does not find it because it is “off screen”

It is important that the image you wish to capture, must be displayed on the screen. Even when executing through an autonomous agent, RDP should be used with a controller agent.
What you could do, if you have a chance, remote desktop to your station and capture the image. If it is off screen, you should scroll until the image is visible. Same must programmed in the WF.

1 Like