How to fetch database from Agent system in AE

We have two machines, one agent and one AE Server,i am not able to access the Database from Agent Machine.


Which database are you trying to access?

I am facing same problem. if server and agent is on same machine then there is no problem, but if they are on different machine then it gives problem.
we have solved it to some extent but we don’t know whether it is correct or not.
We are using postgres database.

Hi Monali,

You misunderstood my question. What I am asking you is that, what do you mean by connecting to database? Do you want to say that you are unable to establish a connection between agent machine and server machine?

no. i am able to establish connection between agent and server.

My problem is different.
I have one workflow that requires to fetch data from any website and store into database. I am not able to access database from server, if i upload workflow on server because my agent is on different machine.

1 Like

Hi @gopal.deshmukh, @monali.pawar
I believe that to access database from another machine, you should first allow access to it by providing IP address in pg_hba.conf you can check it from automation edge installation guide.

5.2 Install Database

allowing remote connection.

if already done please revert my answer

We have done the same thing. We add the agent IP address in pg_hba.conf file .
and we succeed in accessing database.

But after doing that we have to make changes in conf file again to access AE server.

1 Like


You are correct about that. @monali.pawar have you created your own database/schema in Postgres and then you are trying to push data into that?

1 Like

yes, We have created our own database in postgres and by changing pg_hba.conf file i gave access of database to agent only.

After that i can not access database as server. I have to make changes in conf file again and have to add server ip address to access database.

1 Like

Hi @monali.pawar
at a time you can provide both the IP addresses of that a server and agent so they can access the data.


How to do that?

1 Like

@aniket.shelke can you please tell us.

1 Like

hi @gopal.deshmukh

Please refer my last comment


Thanks I’ll try

1 Like

@monali.pawar & @gopal.deshmukh kindly post here once you have tried this and if your problem was solved or not.

1 Like

ok we will let you know.

Hello @gopal.deshmukh, @monali.pawar

In your case AE server and PostgreSQL database might have installed on two different machines then you need to enable remote connections to access the database.

In order to do so you need to make the changes in pg_hba.conf of postgres.

The file is available at below postgres location
C:\Program Files\PostgreSQL\9.5\data\pg_hba.conf

To access this file in postgress go in file menu of postgres( PG_Admin III )

Open the file and make the following changes.

host all postgres IP of AE Server/32 md5
host all postgres IP of AE Agent/32 md5

I have enclosed the screenshot, Please check it and do the changes as stated above.

Please let me know if your issue is resolved by doing above changes.

Thanks and Regards,
Archana Muley

1 Like

We tried this and I am able to access database as a server now.

1 Like

Make sure that you are mentioning server_machine_IP in host name: in your workflow database Connection.


yes i agree with @gopal.deshmukh if we assign hostname as localhost then it will create database on agent side and it look for table in agent system.