Surface click is not working for VisualSVN Server Standalone application

Dear Team,

I am trying to perform some action in VisualSVN Server Manager application using Surface Plugins but Surface click is not working for VisualSVN Server Standalone application.
What is the workaround for this issue and why the surface/windows spy is not working for this application?

Hi @gahana,
Is the VisualSVN Server standalone application behind a remote desktop or a citrix server? I am trying to understand why you are using surface plugin for the same. If it is on your desktop, have you tried Windows Application GUI plugin for the same?

Hello @hemanshu.rukadikar

The VisualSVN Server standalone application is nether behind a remote desktop nor a citrix server. Its the application installed in the same machine as my development machine.
And yes I have tried using Windows Application GUI Plugins but Windows spy is also not working for the VisualSVN application.

Thanks for the update. Can I download this software? Id yes, can you please share the link?


I hope I downloaded the correct application. I think you might have missed adding the start step. Recorded a quick video for you, hope this helps:

1 Like

Hi @hemanshu.rukadikar

Thank you for recreating the scenario and explaining it. I am also trying to achieve this in the same way but I am not able to spy the SVN application. I could only launch it.
I have demonstrated the same in this below video.
Currently I am using AE version 6.0, do I need to update?


Thanks for sharing the video. Appreciate your efforts. Two things:

  1. Have you tried using the ~ key instead? Just press ` key and check?

  2. Is this a local instance or one of our cloud instances? If you are 6.0, most probably this is an OnPrem deployment but want to confirm once.

Yes! I have tried using both Shift and ~ key, none of them are working.
AE 6.0 is an OnPrem and Local Instance.


Can you please tell me from the plugin screen, the version of your WAG plugin?

The version of my Windows-App-GUI plugin is 2.0

That is the latest version for 6.x. Let me have a word with my devs as to why this may be causing an issue.

Sure. Please keep me posted.

Hello @hemanshu.rukadikar

I didn’t want to bother you but anxiously waiting for an update on this issue.

No worries.
We actually also asked a few partners and our internal teams to try this out but we could not reproduce the issue anywhere. Is there any other machine on which you can try this out and let us know?

Hello @hemanshu.rukadikar
Yes! I have tried with other 2 machines also but I am facing the same issue.

Have you ensured all the pre-requites are met for this plugin?

I have gone through the PDF documents but there is no specific pre-requites for this plugin. And these plugins are working completely fine with other applications.

If there is any specific pre-requite for this plugin, please do let me know.


Just .NET 4.5 which you clearly have otherwise the spy would not have detected anything or started in first place. Can you please share the configurations of the machines on which you have tried this?