Agent can't execute while being called via Agent Controller

During this week we carried out several tests on an environment of one of our cllients with the Agent Controller, the test was made on two Windows Server 2022 VMs. Our objective was to run an Agent without a person needing to keep a VM open, we tested and the Agent Controller is able to open the session on the VM we need like this:

However, after the session is opened, nothing happens, and after about 3 minutes the Agent returns this error:

We tried to make all the settings correctly in gpedit.msc and regedit, both in the controller and in the Agent VM, we even rebooted both VMs and the error persists. We also tried to do this with two different users on the same VM and the same error repeated itself.

After this, we tried to do the tests on our own environment.

The first test we did was with two virtual machines, the controller being Windows Server 2022 and the Agent being Windows 10, both were outside of an Active Directory, the robot ran correctly, as expected, then we inverted it and placed the Agent on Windows Server 2022 and the controller on Windows 10 and the result was a success again.

After that, we proceeded to the second test, which we did with two Windows Server 2022 virtual machines that were outside an Active Directory, one of the machines was with the controller and the other with the Agent and the robot ran correctly, as expected, thus eliminating the possibility of the problem being on Windows Server 2022.

Then we created a virtual environment composed of 3 virtual machines, one being the Active Directory server, another for the Agent, and the last for the Agent Controller, and we also created the users and in the Active Directory, we named it like this to stay similar with how is on our client environment. We use to log in to the Agent Controller VM and to log in to the Agent VM. The program ran correctly, we also did another test, where we ran the Agent on the Active Directory machine logged in with, which also worked correctly.

The last test was done by mimicking some of our client Active Directory security policies, and the execution was a success.

With all these tests we were able to eliminate the following error possibilities:

Network communication error
Operating System Error
Active Directory Error

However, we are still unable to conclude what is causing the error in our client environment.

Another detail of the tests that we made on our own environment was that we did not change nothing on gpedit.msc and regedit, and even without the changes it worked just fine.

Can someone help us to discover what is causing the error on our client envirorment?


1 Like

Hello @ViniciusCardoso,

Set DisablePasswordSaving=0 in registry entry on agent machine and also add the server IP in enable policies on Controller machine.


Could you be more specific about the policies on Agent Controller part?